Update packs
This commit is contained in:
parent
497d009c26
commit
17e5f1dd92
@ -3,14 +3,13 @@
|
||||
# Maintainer: Bart Ribbers <bribbers@disroot.org>
|
||||
pkgname=arm-trusted-firmware
|
||||
pkgver=2.6
|
||||
pkgrel=0
|
||||
pkgrel=2
|
||||
pkgdesc="ARM Trusted Firmware-A (TF-A)"
|
||||
url="https://github.com/ARM-software/arm-trusted-firmware"
|
||||
arch="aarch64"
|
||||
license="BSD-3-Clause"
|
||||
makedepends="dtc openssl1.1-compat-dev gcc-arm-none-eabi"
|
||||
source="https://github.com/ARM-software/arm-trusted-firmware/archive/v$pkgver/arm-trusted-firmware-v$pkgver.tar.gz
|
||||
rk3399-baudrate.patch"
|
||||
source="https://github.com/ARM-software/arm-trusted-firmware/archive/v$pkgver/arm-trusted-firmware-v$pkgver.tar.gz"
|
||||
options="!check" # No tests
|
||||
|
||||
_plats="sun50i_a64 sun50i_h6 rk3399"
|
||||
@ -39,5 +38,4 @@ package() {
|
||||
|
||||
sha512sums="
|
||||
8b20964b1b672898268e27424984af0ef9e95b38f426370ed4b802f67fc204db5f467886707dce77e4560548e01777a6c36d4eb801842c7d1f2ff6ca5d9b7dd1 arm-trusted-firmware-v2.6.tar.gz
|
||||
86d8c60157145ab05e9b870aad11d2acaf2137ba00bf71419f8a54a4fd2b1906c19bc8bfeccc735344d1dcf11ba81bd9396bfd8854cdb972a72503b632d1e900 rk3399-baudrate.patch
|
||||
"
|
||||
|
@ -1,23 +0,0 @@
|
||||
From b3fc3a853b8357afd3a010a765072d27f640f5e8 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Andrius=20=C5=A0tikonas?= <andrius@stikonas.eu>
|
||||
Date: Sat, 14 Sep 2019 11:09:01 +0100
|
||||
Subject: [PATCH] Increase BAUD_RATE to 1500000, so that it matches U-Boot and
|
||||
kernel.
|
||||
|
||||
---
|
||||
plat/rockchip/rk3399/rk3399_def.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/plat/rockchip/rk3399/rk3399_def.h b/plat/rockchip/rk3399/rk3399_def.h
|
||||
index ba83242e..8d6ecfbe 100644
|
||||
--- a/plat/rockchip/rk3399/rk3399_def.h
|
||||
+++ b/plat/rockchip/rk3399/rk3399_def.h
|
||||
@@ -17,7 +17,7 @@
|
||||
/**************************************************************************
|
||||
* UART related constants
|
||||
**************************************************************************/
|
||||
-#define RK3399_BAUDRATE 115200
|
||||
+#define RK3399_BAUDRATE 1500000
|
||||
#define RK3399_UART_CLOCK 24000000
|
||||
|
||||
/******************************************************************************
|
@ -8,6 +8,7 @@ url="none"
|
||||
arch="noarch"
|
||||
license="CC0-1.0"
|
||||
builddir="$srcdir/"
|
||||
depends="s6-linux-init"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
|
@ -1,8 +1,8 @@
|
||||
# Contributor: Alex Denes <caskd@redxen.eu>
|
||||
# Maintainer: Alex Denes <caskd@redxen.eu>
|
||||
pkgname=nnd-s6-services
|
||||
pkgver=0.7
|
||||
pkgrel=3
|
||||
pkgver=0.8
|
||||
pkgrel=0
|
||||
pkgdesc="Base services for s6"
|
||||
url="none"
|
||||
arch="noarch"
|
||||
|
@ -8,4 +8,4 @@ define READFROM /proc/kmsg
|
||||
|
||||
fdmove -c 2 1
|
||||
|
||||
foreground { redirfd -r 0 ${READFROM} } ucspilogd
|
||||
redirfd -r 0 $READFROM ucspilogd
|
||||
|
@ -1,20 +1,15 @@
|
||||
The new u-boot releases bring up HDMI and USB and it causes the kernel or u-boot to hang
|
||||
on most boot tries. USE_PREBOOT is disabled so USB won't be brought up which causes an hang
|
||||
after 2020.10 and HDMI being on confuses Linux enough to break everything.
|
||||
diff --git a/configs/rockpro64-rk3399_defconfig b/configs/rockpro64-rk3399_defconfig
|
||||
index ae11a8f5eb..aa8f55639c 100644
|
||||
--- a/configs/rockpro64-rk3399_defconfig
|
||||
+++ b/configs/rockpro64-rk3399_defconfig
|
||||
@@ -12,7 +12,7 @@ CONFIG_DEBUG_UART_CLOCK=24000000
|
||||
CONFIG_SPL_SPI_FLASH_SUPPORT=y
|
||||
CONFIG_SPL_SPI_SUPPORT=y
|
||||
@@ -14,7 +14,7 @@
|
||||
CONFIG_SPL_SPI=y
|
||||
CONFIG_DEBUG_UART=y
|
||||
CONFIG_SYS_LOAD_ADDR=0x800800
|
||||
-CONFIG_USE_PREBOOT=y
|
||||
+CONFIG_USE_PREBOOT=n
|
||||
CONFIG_DEFAULT_FDT_FILE="rockchip/rk3399-rockpro64.dtb"
|
||||
CONFIG_DISPLAY_BOARDINFO_LATE=y
|
||||
CONFIG_MISC_INIT_R=y
|
||||
@@ -81,6 +81,6 @@ CONFIG_USB_ETHER_SMSC95XX=y
|
||||
@@ -83,6 +83,6 @@
|
||||
CONFIG_DM_VIDEO=y
|
||||
CONFIG_DISPLAY=y
|
||||
CONFIG_VIDEO_ROCKCHIP=y
|
||||
|
@ -2,8 +2,8 @@
|
||||
# Contributor: Timo Teras <timo.teras@iki.fi>
|
||||
# Maintainer: Milan P. Stanić <mps@arvanta.net>
|
||||
pkgname=u-boot
|
||||
pkgver=2021.10
|
||||
pkgrel=6
|
||||
pkgver=2022.01
|
||||
pkgrel=0
|
||||
pkgdesc="u-boot bootloader common files"
|
||||
url="https://www.denx.de/wiki/U-Boot/"
|
||||
arch="all !s390x !ppc64le"
|
||||
@ -18,6 +18,9 @@ source="https://ftp.denx.de/pub/u-boot/u-boot-${pkgver//_/-}.tar.bz2
|
||||
README.txt
|
||||
update-u-boot
|
||||
hifive-unmatched-ramdisk.patch
|
||||
0001-rockpro64-fix-boot-hang.patch
|
||||
0002-rockpro64-baudrate.patch
|
||||
fix-tools-build.patch
|
||||
"
|
||||
builddir="$srcdir"/u-boot-${pkgver//_/-}
|
||||
|
||||
@ -181,8 +184,11 @@ for board_config in $board_configs; do
|
||||
done
|
||||
|
||||
sha512sums="
|
||||
be5be1c9a54b270307a04177d5577a21c57a02b307bf8b63d0fa2655d1f025c7ce010dca6a1f7f60d4e639c2e6fb6f0a292a2e5d190f1fad478eb12dd786c9da u-boot-2021.10.tar.bz2
|
||||
d83c62bd8f0f51664d2aca329a3ce1379cfd1dfff439dccd6cfc2cb33cfef89a2b01855c97716f591b5550bfdf99e2f3aef7efa33f2e7834c820648f9eef3825 u-boot-2022.01.tar.bz2
|
||||
f8c9bb6e84d6f0620c976ac7ad5dd7ec7ff9dfdd4b1d03d2bf6653e7beccf80bdf2debfc92fb1f696dba92fb40287d3c45897e0078951451d0835cb61a5f16d1 README.txt
|
||||
b5b5960a70c0edab38c208e5a41f2130c673334e05ef77dd4c839d59365d4243590a79bf3865914397b600550f4d0f69f8145e51a7ef05aa0190420fcc7ff02d update-u-boot
|
||||
1e8c95a37e7efb74f6519f66da44a0050417066aa2bd6d38e8a7e7135f501a9578dcc3701f66a170bf4cbd5c17b87d69ff80760979b1aa31d26e75be7cf7b97f hifive-unmatched-ramdisk.patch
|
||||
27253e065a46a4563522fcb9551d51d68e0114ba8964c0be5067dbe2e94b0cf1b197490c17ad394d29603a21ab8c5d17daf0b3bc9bcfff704d8070e26b0b4761 0001-rockpro64-fix-boot-hang.patch
|
||||
e506f06071966922db393620212cf38b0d456bf517e9a719a5f2191fa815f37c17f7a1650e78742ea29bcb05f5cd63d5e8a88fb48dbd224539ae7188efdcf823 0002-rockpro64-baudrate.patch
|
||||
3b900d833ee7d82ee3bca6e8f8cb8e297359bb65c3f095a0d22377779eb8a233c5e566e5db6ce79f3076fbe6413d002941eb9cc450e3462337f46c1805472ce0 fix-tools-build.patch
|
||||
"
|
||||
|
17
main/u-boot/fix-tools-build.patch
Normal file
17
main/u-boot/fix-tools-build.patch
Normal file
@ -0,0 +1,17 @@
|
||||
Author: Milan P. Stanić <mps@arvanta.net>
|
||||
Date: Thu Jan 143 21:33:42 2022 +0000
|
||||
|
||||
musl libc doesn't have c_ospeed and c_ispeed types so disable
|
||||
build of kwboot with this patch
|
||||
|
||||
--- a/tools/Makefile 2022-01-10 18:46:34.000000000 +0000
|
||||
+++ b/tools/Makefile 2022-01-14 20:26:13.814939412 +0000
|
||||
@@ -217,8 +217,6 @@
|
||||
|
||||
HOSTCFLAGS_ubsha1.o := -pedantic
|
||||
|
||||
-hostprogs-$(CONFIG_ARCH_KIRKWOOD) += kwboot
|
||||
-hostprogs-$(CONFIG_ARCH_MVEBU) += kwboot
|
||||
hostprogs-y += proftool
|
||||
hostprogs-$(CONFIG_STATIC_RELA) += relocate-rela
|
||||
hostprogs-$(CONFIG_RISCV) += prelink-riscv
|
Loading…
Reference in New Issue
Block a user