Add sbase
This commit is contained in:
parent
9e8c7a3c0d
commit
4260a8cd97
34
util/sbase/APKBUILD
Normal file
34
util/sbase/APKBUILD
Normal file
@ -0,0 +1,34 @@
|
||||
# Contributor: Alex Denes <caskd@redxen.eu>
|
||||
# Maintainer: Alex Denes <caskd@redxen.eu>
|
||||
pkgname=sbase
|
||||
_commit="7d60e2cabbe07495ee74f3d5e705f1e3470148eb"
|
||||
pkgver="0.0_git"
|
||||
pkgrel=0
|
||||
pkgdesc="suckless unix tools"
|
||||
url="https://core.suckless.org/sbase/"
|
||||
arch="all"
|
||||
license="MIT"
|
||||
makedepends="
|
||||
make
|
||||
"
|
||||
#cc
|
||||
subpackages="$pkgname-doc"
|
||||
source="
|
||||
$pkgname-$pkgver-$_commit.tar.gz::https://git.redxen.eu/suckless/sbase/archive/$_commit.tar.gz
|
||||
config.patch
|
||||
"
|
||||
builddir="$srcdir/sbase"
|
||||
options="!check"
|
||||
|
||||
build() {
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
9b1734e8968947c47bf2c3de51a9472daa3a835e6f9f0a233be5765e82d4eea3dc16c47944a8693fa3484b34a12817c2da40a263b3fa046e91c03a3f1416155e sbase-0.0_git-7d60e2cabbe07495ee74f3d5e705f1e3470148eb.tar.gz
|
||||
5038e847feddeaaed565b52070f580122337e2ebde205459f6b08a88f7ac040302f6dcb20c18de501117e0aa34d5c3fa0ed756bb35b66ac9a56231d53116dcc1 config.patch
|
||||
"
|
17
util/sbase/config.patch
Normal file
17
util/sbase/config.patch
Normal file
@ -0,0 +1,17 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -2,7 +2,7 @@
|
||||
VERSION = 0.0
|
||||
|
||||
# paths
|
||||
-PREFIX = /usr/local
|
||||
+PREFIX = /usr
|
||||
MANPREFIX = $(PREFIX)/share/man
|
||||
|
||||
CC = cc
|
||||
@@ -13,4 +13,4 @@
|
||||
# -lrt might be needed on some systems
|
||||
CPPFLAGS = -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_XOPEN_SOURCE=700 -D_FILE_OFFSET_BITS=64
|
||||
CFLAGS = -std=c99 -Wall -pedantic
|
||||
-LDFLAGS = -s
|
||||
+LDFLAGS = -s -static
|
Loading…
Reference in New Issue
Block a user