bcm53xx: add early support for Linksys EA6300 V1
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 47052
This commit is contained in:
parent
877f2972d4
commit
c6401c6d61
@ -87,6 +87,18 @@ define AsusDevice
|
|||||||
TARGET_DEVICES += asus-$(1)
|
TARGET_DEVICES += asus-$(1)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Device/linksys
|
||||||
|
IMAGES := trx
|
||||||
|
IMAGE/trx := trx-nand
|
||||||
|
endef
|
||||||
|
|
||||||
|
define LinksysDevice
|
||||||
|
define Device/linksys-$(1)
|
||||||
|
$$(Device/linksys)
|
||||||
|
endef
|
||||||
|
TARGET_DEVICES += linksys-$(1)
|
||||||
|
endef
|
||||||
|
|
||||||
define Device/netgear
|
define Device/netgear
|
||||||
IMAGES := chk
|
IMAGES := chk
|
||||||
IMAGE/chk := trx-nand | netgear-chk
|
IMAGE/chk := trx-nand | netgear-chk
|
||||||
@ -131,6 +143,7 @@ $(eval $(call AsusDevice,rt-ac56u,RT-AC56U))
|
|||||||
$(eval $(call AsusDevice,rt-ac68u,RT-AC68U))
|
$(eval $(call AsusDevice,rt-ac68u,RT-AC68U))
|
||||||
$(eval $(call AsusDevice,rt-ac87u,RT-AC87U))
|
$(eval $(call AsusDevice,rt-ac87u,RT-AC87U))
|
||||||
$(eval $(call AsusDevice,rt-n18u,RT-N18U))
|
$(eval $(call AsusDevice,rt-n18u,RT-N18U))
|
||||||
|
$(eval $(call LinksysDevice,ea6300-v1))
|
||||||
$(eval $(call NetgearDevice,r7000,U12H270T00_NETGEAR))
|
$(eval $(call NetgearDevice,r7000,U12H270T00_NETGEAR))
|
||||||
|
|
||||||
$(eval $(call BuildImage))
|
$(eval $(call BuildImage))
|
||||||
|
@ -0,0 +1,72 @@
|
|||||||
|
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
|
||||||
|
Subject: [PATCH] ARM: BCM5301X: Add DT for Linksys EA6300 V1
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
||||||
|
---
|
||||||
|
--- a/arch/arm/boot/dts/Makefile
|
||||||
|
+++ b/arch/arm/boot/dts/Makefile
|
||||||
|
@@ -59,6 +59,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
||||||
|
bcm4708-asus-rt-ac56u.dtb \
|
||||||
|
bcm4708-asus-rt-ac68u.dtb \
|
||||||
|
bcm4708-buffalo-wzr-1750dhp.dtb \
|
||||||
|
+ bcm4708-linksys-ea6300-v1.dtb \
|
||||||
|
bcm4708-luxul-xwc-1000.dtb \
|
||||||
|
bcm4708-netgear-r6250.dtb \
|
||||||
|
bcm4708-netgear-r6300-v2.dtb \
|
||||||
|
diff --git a/arch/arm/boot/dts/bcm4708-linksys-ea6300-v1.dts b/arch/arm/boot/dts/bcm4708-linksys-ea6300-v1.dts
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..705d0c2
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/arch/arm/boot/dts/bcm4708-linksys-ea6300-v1.dts
|
||||||
|
@@ -0,0 +1,48 @@
|
||||||
|
+/*
|
||||||
|
+ * Broadcom BCM470X / BCM5301X ARM platform code.
|
||||||
|
+ * DTS for Linksys EA6300 V1
|
||||||
|
+ *
|
||||||
|
+ * Copyright (C) 2015 Rafał Miłecki <zajec5@gmail.com>
|
||||||
|
+ *
|
||||||
|
+ * Licensed under the GNU/GPL. See COPYING for details.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+/dts-v1/;
|
||||||
|
+
|
||||||
|
+#include "bcm4708.dtsi"
|
||||||
|
+#include "bcm5301x-nand-cs0-bch8.dtsi"
|
||||||
|
+
|
||||||
|
+/ {
|
||||||
|
+ compatible = "linksys,ea6300v1", "brcm,bcm4708";
|
||||||
|
+ model = "Linksys EA6300 V1";
|
||||||
|
+
|
||||||
|
+ chosen {
|
||||||
|
+ bootargs = "console=ttyS0,115200";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ memory {
|
||||||
|
+ reg = <0x00000000 0x08000000>;
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ gpio-keys {
|
||||||
|
+ compatible = "gpio-keys";
|
||||||
|
+ #address-cells = <1>;
|
||||||
|
+ #size-cells = <0>;
|
||||||
|
+
|
||||||
|
+ wps {
|
||||||
|
+ label = "WPS";
|
||||||
|
+ linux,code = <KEY_WPS_BUTTON>;
|
||||||
|
+ gpios = <&chipcommon 7 GPIO_ACTIVE_LOW>;
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ restart {
|
||||||
|
+ label = "Reset";
|
||||||
|
+ linux,code = <KEY_RESTART>;
|
||||||
|
+ gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
|
||||||
|
+ };
|
||||||
|
+ };
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+&uart0 {
|
||||||
|
+ status = "okay";
|
||||||
|
+};
|
@ -156,4 +156,15 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
|||||||
+ bootargs = "console=ttyS0,115200 earlyprintk";
|
+ bootargs = "console=ttyS0,115200 earlyprintk";
|
||||||
};
|
};
|
||||||
|
|
||||||
|
memory {
|
||||||
|
--- a/arch/arm/boot/dts/bcm4708-linksys-ea6300-v1.dts
|
||||||
|
+++ b/arch/arm/boot/dts/bcm4708-linksys-ea6300-v1.dts
|
||||||
|
@@ -17,7 +17,7 @@
|
||||||
|
model = "Linksys EA6300 V1";
|
||||||
|
|
||||||
|
chosen {
|
||||||
|
- bootargs = "console=ttyS0,115200";
|
||||||
|
+ bootargs = "console=ttyS0,115200 earlyprintk";
|
||||||
|
};
|
||||||
|
|
||||||
memory {
|
memory {
|
||||||
|
Loading…
Reference in New Issue
Block a user