parent
f88ddb8ba8
commit
c0310c2f5f
@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
|
|||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=sangam_atm
|
PKG_NAME:=sangam_atm
|
||||||
PKG_VERSION:=07.02.01.00
|
PKG_VERSION:=D7.03.01.00
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=R2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_RELEASE).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_RELEASE).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
|
PKG_SOURCE_URL:=http://teknoraver.campuslife.it/software
|
||||||
PKG_MD5SUM:=240558504afe41aeb472301d2e3fa052
|
PKG_MD5SUM:=bc6e9c6adb1be25820c7ee661de8ca7d
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -urN sangam_atm-07.02.01.00/cppi_cpaal5.c sangam_atm-07.02.01.00.new/cppi_cpaal5.c
|
diff -urN sangam_atm-D7.03.01.00.orig/cppi_cpaal5.c sangam_atm-D7.03.01.00/cppi_cpaal5.c
|
||||||
--- sangam_atm-07.02.01.00/cppi_cpaal5.c 2007-08-06 18:15:52.000000000 +0200
|
--- sangam_atm-D7.03.01.00.orig/cppi_cpaal5.c 2005-04-08 10:22:04.000000000 +0200
|
||||||
+++ sangam_atm-07.02.01.00.new/cppi_cpaal5.c 2007-10-04 16:17:43.000000000 +0200
|
+++ sangam_atm-D7.03.01.00/cppi_cpaal5.c 2008-01-05 03:11:03.000000000 +0100
|
||||||
@@ -352,7 +352,7 @@
|
@@ -352,7 +352,7 @@
|
||||||
{
|
{
|
||||||
/* malloc failed, add this RCB to Needs Buffer List */
|
/* malloc failed, add this RCB to Needs Buffer List */
|
||||||
@ -10,12 +10,12 @@ diff -urN sangam_atm-07.02.01.00/cppi_cpaal5.c sangam_atm-07.02.01.00.new/cppi_c
|
|||||||
|
|
||||||
if(HalDev->NeedsCount < MAX_NEEDS) /* +MJH 030410 */
|
if(HalDev->NeedsCount < MAX_NEEDS) /* +MJH 030410 */
|
||||||
{ /* +MJH 030410 */
|
{ /* +MJH 030410 */
|
||||||
diff -urN sangam_atm-07.02.01.00/dsl_hal_api.c sangam_atm-07.02.01.00.new/dsl_hal_api.c
|
diff -urN sangam_atm-D7.03.01.00.orig/dsl_hal_api.c sangam_atm-D7.03.01.00/dsl_hal_api.c
|
||||||
--- sangam_atm-07.02.01.00/dsl_hal_api.c 2007-08-06 18:15:52.000000000 +0200
|
--- sangam_atm-D7.03.01.00.orig/dsl_hal_api.c 2007-03-07 04:13:06.000000000 +0100
|
||||||
+++ sangam_atm-07.02.01.00.new/dsl_hal_api.c 2007-10-04 16:17:43.000000000 +0200
|
+++ sangam_atm-D7.03.01.00/dsl_hal_api.c 2008-01-05 03:11:03.000000000 +0100
|
||||||
@@ -241,15 +241,15 @@
|
@@ -254,15 +254,15 @@
|
||||||
* UR8_MERGE_START_END CQ11247_TR69_DS_LATN_SATN YW
|
* of phyEnableDisableWord & phyControlWord to avoid changing API struct
|
||||||
* 12/18/06 Yan Wang CQ11247: TR069 range and precision changes for LATNds, SATNds
|
* which may cause change required to application data structure.
|
||||||
******************************************************************************/
|
******************************************************************************/
|
||||||
-#include <dev_host_interface.h>
|
-#include <dev_host_interface.h>
|
||||||
-#include <dsl_hal_register.h>
|
-#include <dsl_hal_register.h>
|
||||||
@ -34,9 +34,9 @@ diff -urN sangam_atm-07.02.01.00/dsl_hal_api.c sangam_atm-07.02.01.00.new/dsl_ha
|
|||||||
|
|
||||||
// UR8_MERGE_START CQ11054 Jack Zhang
|
// UR8_MERGE_START CQ11054 Jack Zhang
|
||||||
static unsigned int highprecision_selected = 0; //By default we use low precision for backward compt.
|
static unsigned int highprecision_selected = 0; //By default we use low precision for backward compt.
|
||||||
diff -urN sangam_atm-07.02.01.00/dsl_hal_support.c sangam_atm-07.02.01.00.new/dsl_hal_support.c
|
diff -urN sangam_atm-D7.03.01.00.orig/dsl_hal_support.c sangam_atm-D7.03.01.00/dsl_hal_support.c
|
||||||
--- sangam_atm-07.02.01.00/dsl_hal_support.c 2007-08-06 18:15:52.000000000 +0200
|
--- sangam_atm-D7.03.01.00.orig/dsl_hal_support.c 2007-05-18 09:47:33.000000000 +0200
|
||||||
+++ sangam_atm-07.02.01.00.new/dsl_hal_support.c 2007-10-04 16:17:43.000000000 +0200
|
+++ sangam_atm-D7.03.01.00/dsl_hal_support.c 2008-01-05 03:11:03.000000000 +0100
|
||||||
@@ -140,9 +140,9 @@
|
@@ -140,9 +140,9 @@
|
||||||
* oamFeature are overriden
|
* oamFeature are overriden
|
||||||
// UR8_MERGE_END CQ10774 Ram
|
// UR8_MERGE_END CQ10774 Ram
|
||||||
@ -50,9 +50,9 @@ diff -urN sangam_atm-07.02.01.00/dsl_hal_support.c sangam_atm-07.02.01.00.new/ds
|
|||||||
|
|
||||||
#define NUM_READ_RETRIES 3
|
#define NUM_READ_RETRIES 3
|
||||||
static unsigned int dslhal_support_adsl2ByteSwap32(unsigned int in32Bits);
|
static unsigned int dslhal_support_adsl2ByteSwap32(unsigned int in32Bits);
|
||||||
diff -urN sangam_atm-07.02.01.00/dsl_hal_support.h sangam_atm-07.02.01.00.new/dsl_hal_support.h
|
diff -urN sangam_atm-D7.03.01.00.orig/dsl_hal_support.h sangam_atm-D7.03.01.00/dsl_hal_support.h
|
||||||
--- sangam_atm-07.02.01.00/dsl_hal_support.h 2007-08-06 18:15:52.000000000 +0200
|
--- sangam_atm-D7.03.01.00.orig/dsl_hal_support.h 2005-11-11 09:07:04.000000000 +0100
|
||||||
+++ sangam_atm-07.02.01.00.new/dsl_hal_support.h 2007-10-04 16:17:43.000000000 +0200
|
+++ sangam_atm-D7.03.01.00/dsl_hal_support.h 2008-01-05 03:11:03.000000000 +0100
|
||||||
@@ -49,7 +49,7 @@
|
@@ -49,7 +49,7 @@
|
||||||
* 04Nov05 0.11.00 CPH Fixed T1413 mode got Zero DS/US rate when DSL_BIT_TMODE is set.
|
* 04Nov05 0.11.00 CPH Fixed T1413 mode got Zero DS/US rate when DSL_BIT_TMODE is set.
|
||||||
*******************************************************************************/
|
*******************************************************************************/
|
||||||
@ -62,9 +62,9 @@ diff -urN sangam_atm-07.02.01.00/dsl_hal_support.h sangam_atm-07.02.01.00.new/ds
|
|||||||
|
|
||||||
#define virtual2Physical(a) (((int)a)&~0xe0000000)
|
#define virtual2Physical(a) (((int)a)&~0xe0000000)
|
||||||
/* External Function Prototype Declarations */
|
/* External Function Prototype Declarations */
|
||||||
diff -urN sangam_atm-07.02.01.00/Makefile sangam_atm-07.02.01.00.new/Makefile
|
diff -urN sangam_atm-D7.03.01.00.orig/Makefile sangam_atm-D7.03.01.00/Makefile
|
||||||
--- sangam_atm-07.02.01.00/Makefile 2007-08-06 18:15:52.000000000 +0200
|
--- sangam_atm-D7.03.01.00.orig/Makefile 2005-06-01 05:46:28.000000000 +0200
|
||||||
+++ sangam_atm-07.02.01.00.new/Makefile 2007-10-04 16:17:43.000000000 +0200
|
+++ sangam_atm-D7.03.01.00/Makefile 2008-01-05 03:11:03.000000000 +0100
|
||||||
@@ -1,18 +1,9 @@
|
@@ -1,18 +1,9 @@
|
||||||
-# File: drivers/atm/ti_evm3/Makefile
|
-# File: drivers/atm/ti_evm3/Makefile
|
||||||
#
|
#
|
||||||
@ -90,9 +90,9 @@ diff -urN sangam_atm-07.02.01.00/Makefile sangam_atm-07.02.01.00.new/Makefile
|
|||||||
+EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
|
+EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
|
||||||
+obj-$(CONFIG_SANGAM_ATM) := tiatm.o
|
+obj-$(CONFIG_SANGAM_ATM) := tiatm.o
|
||||||
+tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o
|
+tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o
|
||||||
diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
diff -urN sangam_atm-D7.03.01.00.orig/tn7atm.c sangam_atm-D7.03.01.00/tn7atm.c
|
||||||
--- sangam_atm-07.02.01.00/tn7atm.c 2007-08-06 18:15:52.000000000 +0200
|
--- sangam_atm-D7.03.01.00.orig/tn7atm.c 2007-05-18 09:45:50.000000000 +0200
|
||||||
+++ sangam_atm-07.02.01.00.new/tn7atm.c 2007-10-04 16:21:50.000000000 +0200
|
+++ sangam_atm-D7.03.01.00/tn7atm.c 2008-01-05 03:11:03.000000000 +0100
|
||||||
@@ -61,7 +61,6 @@
|
@@ -61,7 +61,6 @@
|
||||||
* UR8_MERGE_END CQ11057*
|
* UR8_MERGE_END CQ11057*
|
||||||
*********************************************************************************************/
|
*********************************************************************************************/
|
||||||
@ -163,7 +163,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
static struct proc_dir_entry *root_proc_dir_entry = NULL;
|
static struct proc_dir_entry *root_proc_dir_entry = NULL;
|
||||||
#define DRV_PROC_MODE 0644
|
#define DRV_PROC_MODE 0644
|
||||||
static int proc_root_already_exists = TRUE;
|
static int proc_root_already_exists = TRUE;
|
||||||
@@ -564,56 +566,6 @@
|
@@ -559,56 +561,6 @@
|
||||||
|
|
||||||
/*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
/*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||||
*
|
*
|
||||||
@ -220,7 +220,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
* Function: int tn7atm_sar_irq(void)
|
* Function: int tn7atm_sar_irq(void)
|
||||||
*
|
*
|
||||||
* Description: tnetd73xx SAR interrupt.
|
* Description: tnetd73xx SAR interrupt.
|
||||||
@@ -709,8 +661,8 @@
|
@@ -704,8 +656,8 @@
|
||||||
{
|
{
|
||||||
def_sar_inter_pace = os_atoi (ptr);
|
def_sar_inter_pace = os_atoi (ptr);
|
||||||
}
|
}
|
||||||
@ -231,7 +231,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
|
|
||||||
/*
|
/*
|
||||||
* Reigster Receive interrupt A
|
* Reigster Receive interrupt A
|
||||||
@@ -880,11 +832,15 @@
|
@@ -875,11 +827,15 @@
|
||||||
#define ATM_VBR_RT 5
|
#define ATM_VBR_RT 5
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -248,7 +248,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
|
|
||||||
dgprintf(1, "tn7atm_open()\n");
|
dgprintf(1, "tn7atm_open()\n");
|
||||||
|
|
||||||
@@ -896,24 +852,18 @@
|
@@ -891,24 +847,18 @@
|
||||||
return -1;
|
return -1;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -279,7 +279,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
{
|
{
|
||||||
/* always use (max_dma_chan+1) for clear eoc */
|
/* always use (max_dma_chan+1) for clear eoc */
|
||||||
tn7atm_activate_vc_parm.chan = EOC_DMA_CHAN;
|
tn7atm_activate_vc_parm.chan = EOC_DMA_CHAN;
|
||||||
@@ -921,7 +871,7 @@
|
@@ -916,7 +866,7 @@
|
||||||
/* check to see whether clear eoc is opened or not */
|
/* check to see whether clear eoc is opened or not */
|
||||||
if (tn7atm_activate_vc_parm.priv->lut[tn7atm_activate_vc_parm.chan].inuse)
|
if (tn7atm_activate_vc_parm.priv->lut[tn7atm_activate_vc_parm.chan].inuse)
|
||||||
{
|
{
|
||||||
@ -288,7 +288,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
printk("tn7atm_open: Clear EOC channel (dmachan=%d) already in use.\n", tn7atm_activate_vc_parm.chan);
|
printk("tn7atm_open: Clear EOC channel (dmachan=%d) already in use.\n", tn7atm_activate_vc_parm.chan);
|
||||||
return -EBUSY;
|
return -EBUSY;
|
||||||
}
|
}
|
||||||
@@ -930,7 +880,7 @@
|
@@ -925,7 +875,7 @@
|
||||||
if (rc)
|
if (rc)
|
||||||
{
|
{
|
||||||
printk("tn7atm_open: failed to setup clear_eoc\n");
|
printk("tn7atm_open: failed to setup clear_eoc\n");
|
||||||
@ -297,7 +297,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
return -EBUSY;
|
return -EBUSY;
|
||||||
}
|
}
|
||||||
tn7atm_set_lut(tn7atm_activate_vc_parm.priv,vcc, tn7atm_activate_vc_parm.chan);
|
tn7atm_set_lut(tn7atm_activate_vc_parm.priv,vcc, tn7atm_activate_vc_parm.chan);
|
||||||
@@ -939,17 +889,17 @@
|
@@ -934,17 +884,17 @@
|
||||||
}
|
}
|
||||||
else /* PVC channel setup */
|
else /* PVC channel setup */
|
||||||
{
|
{
|
||||||
@ -318,7 +318,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
printk("PVC already opened. dmachan = %d\n", rc);
|
printk("PVC already opened. dmachan = %d\n", rc);
|
||||||
return -EBUSY;
|
return -EBUSY;
|
||||||
}
|
}
|
||||||
@@ -981,6 +931,7 @@
|
@@ -976,6 +926,7 @@
|
||||||
tn7atm_activate_vc_parm.priority = 2;
|
tn7atm_activate_vc_parm.priority = 2;
|
||||||
break;
|
break;
|
||||||
|
|
||||||
@ -326,7 +326,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
case ATM_VBR: /* Variable Bit Rate-Non RealTime*/
|
case ATM_VBR: /* Variable Bit Rate-Non RealTime*/
|
||||||
tn7atm_activate_vc_parm.qos = 1;
|
tn7atm_activate_vc_parm.qos = 1;
|
||||||
tn7atm_activate_vc_parm.priority = 1;
|
tn7atm_activate_vc_parm.priority = 1;
|
||||||
@@ -1002,6 +953,7 @@
|
@@ -997,6 +948,7 @@
|
||||||
tn7atm_activate_vc_parm.mbs = vcc->qos.txtp.max_pcr;
|
tn7atm_activate_vc_parm.mbs = vcc->qos.txtp.max_pcr;
|
||||||
tn7atm_activate_vc_parm.cdvt = vcc->qos.txtp.max_cdv;
|
tn7atm_activate_vc_parm.cdvt = vcc->qos.txtp.max_cdv;
|
||||||
break;
|
break;
|
||||||
@ -334,7 +334,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
|
|
||||||
default:
|
default:
|
||||||
tn7atm_activate_vc_parm.qos = 2;
|
tn7atm_activate_vc_parm.qos = 2;
|
||||||
@@ -1029,7 +981,7 @@
|
@@ -1024,7 +976,7 @@
|
||||||
if (rc < 0)
|
if (rc < 0)
|
||||||
{
|
{
|
||||||
printk("failed to activate hw channel\n");
|
printk("failed to activate hw channel\n");
|
||||||
@ -343,7 +343,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
tn7atm_lut_clear(vcc, tn7atm_activate_vc_parm.chan);
|
tn7atm_lut_clear(vcc, tn7atm_activate_vc_parm.chan);
|
||||||
//spin_unlock_irqrestore(&chan_init_lock, flags);
|
//spin_unlock_irqrestore(&chan_init_lock, flags);
|
||||||
return -EBUSY;
|
return -EBUSY;
|
||||||
@@ -1119,7 +1071,7 @@
|
@@ -1114,7 +1066,7 @@
|
||||||
tn7atm_lut_clear (vcc, dmachan);
|
tn7atm_lut_clear (vcc, dmachan);
|
||||||
//spin_unlock_irqrestore (&closeLock, closeFlag);
|
//spin_unlock_irqrestore (&closeLock, closeFlag);
|
||||||
|
|
||||||
@ -352,7 +352,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
|
|
||||||
dgprintf (1, "Leave tn7atm_close\n");
|
dgprintf (1, "Leave tn7atm_close\n");
|
||||||
}
|
}
|
||||||
@@ -1533,8 +1485,7 @@
|
@@ -1528,8 +1480,7 @@
|
||||||
* firewall is on */
|
* firewall is on */
|
||||||
|
|
||||||
dgprintf (3, "pushing the skb...\n");
|
dgprintf (3, "pushing the skb...\n");
|
||||||
@ -362,7 +362,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
|
|
||||||
xdump ((unsigned char *) skb->data, skb->len, 5);
|
xdump ((unsigned char *) skb->data, skb->len, 5);
|
||||||
|
|
||||||
@@ -1730,8 +1681,7 @@
|
@@ -1725,8 +1676,7 @@
|
||||||
|
|
||||||
kfree (dev->dev_data);
|
kfree (dev->dev_data);
|
||||||
|
|
||||||
@ -372,7 +372,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
|
|
||||||
/*
|
/*
|
||||||
* remove proc entries
|
* remove proc entries
|
||||||
@@ -1890,9 +1840,6 @@
|
@@ -1885,9 +1835,6 @@
|
||||||
/*
|
/*
|
||||||
* Set up proc entry for atm stats
|
* Set up proc entry for atm stats
|
||||||
*/
|
*/
|
||||||
@ -382,7 +382,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
printk ("Creating new root folder %s in the proc for the driver stats \n",
|
printk ("Creating new root folder %s in the proc for the driver stats \n",
|
||||||
drv_proc_root_folder);
|
drv_proc_root_folder);
|
||||||
root_proc_dir_entry = proc_mkdir (drv_proc_root_folder, NULL);
|
root_proc_dir_entry = proc_mkdir (drv_proc_root_folder, NULL);
|
||||||
@@ -1902,7 +1849,6 @@
|
@@ -1897,7 +1844,6 @@
|
||||||
return -ENOMEM;
|
return -ENOMEM;
|
||||||
}
|
}
|
||||||
proc_root_already_exists = FALSE;
|
proc_root_already_exists = FALSE;
|
||||||
@ -390,7 +390,7 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
|
|
||||||
/*
|
/*
|
||||||
* AV: Clean-up. Moved all the definitions to the data structure.
|
* AV: Clean-up. Moved all the definitions to the data structure.
|
||||||
@@ -2484,7 +2430,5 @@
|
@@ -2479,7 +2425,5 @@
|
||||||
return count;
|
return count;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -398,9 +398,9 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00.new/tn7atm.c
|
|||||||
module_init (tn7atm_detect);
|
module_init (tn7atm_detect);
|
||||||
module_exit (tn7atm_exit);
|
module_exit (tn7atm_exit);
|
||||||
-#endif /* MODULE */
|
-#endif /* MODULE */
|
||||||
diff -urN sangam_atm-07.02.01.00/tn7atm.h sangam_atm-07.02.01.00.new/tn7atm.h
|
diff -urN sangam_atm-D7.03.01.00.orig/tn7atm.h sangam_atm-D7.03.01.00/tn7atm.h
|
||||||
--- sangam_atm-07.02.01.00/tn7atm.h 2007-08-06 18:15:52.000000000 +0200
|
--- sangam_atm-D7.03.01.00.orig/tn7atm.h 2006-04-05 07:33:06.000000000 +0200
|
||||||
+++ sangam_atm-07.02.01.00.new/tn7atm.h 2007-10-04 16:17:43.000000000 +0200
|
+++ sangam_atm-D7.03.01.00/tn7atm.h 2008-01-05 03:11:03.000000000 +0100
|
||||||
@@ -19,7 +19,8 @@
|
@@ -19,7 +19,8 @@
|
||||||
//#include "mips_support.h"
|
//#include "mips_support.h"
|
||||||
#include <linux/list.h>
|
#include <linux/list.h>
|
||||||
@ -411,9 +411,9 @@ diff -urN sangam_atm-07.02.01.00/tn7atm.h sangam_atm-07.02.01.00.new/tn7atm.h
|
|||||||
|
|
||||||
#ifdef CONFIG_MODVERSIONS
|
#ifdef CONFIG_MODVERSIONS
|
||||||
#include <linux/modversions.h>
|
#include <linux/modversions.h>
|
||||||
diff -urN sangam_atm-07.02.01.00/tn7dsl.c sangam_atm-07.02.01.00.new/tn7dsl.c
|
diff -urN sangam_atm-D7.03.01.00.orig/tn7dsl.c sangam_atm-D7.03.01.00/tn7dsl.c
|
||||||
--- sangam_atm-07.02.01.00/tn7dsl.c 2007-08-06 18:15:52.000000000 +0200
|
--- sangam_atm-D7.03.01.00.orig/tn7dsl.c 2007-01-04 09:04:14.000000000 +0100
|
||||||
+++ sangam_atm-07.02.01.00.new/tn7dsl.c 2007-10-04 16:23:53.000000000 +0200
|
+++ sangam_atm-D7.03.01.00/tn7dsl.c 2008-01-05 03:11:03.000000000 +0100
|
||||||
@@ -94,7 +94,6 @@
|
@@ -94,7 +94,6 @@
|
||||||
* 1/02/07 JZ CQ11054: Data Precision and Range Changes for TR-069 Conformance
|
* 1/02/07 JZ CQ11054: Data Precision and Range Changes for TR-069 Conformance
|
||||||
* UR8_MERGE_END CQ11054*
|
* UR8_MERGE_END CQ11054*
|
||||||
@ -691,9 +691,9 @@ diff -urN sangam_atm-07.02.01.00/tn7dsl.c sangam_atm-07.02.01.00.new/tn7dsl.c
|
|||||||
|
|
||||||
/*
|
/*
|
||||||
* set the defaults
|
* set the defaults
|
||||||
diff -urN sangam_atm-07.02.01.00/tn7sar.c sangam_atm-07.02.01.00.new/tn7sar.c
|
diff -urN sangam_atm-D7.03.01.00.orig/tn7sar.c sangam_atm-D7.03.01.00/tn7sar.c
|
||||||
--- sangam_atm-07.02.01.00/tn7sar.c 2007-08-06 18:15:52.000000000 +0200
|
--- sangam_atm-D7.03.01.00.orig/tn7sar.c 2007-05-18 09:46:30.000000000 +0200
|
||||||
+++ sangam_atm-07.02.01.00.new/tn7sar.c 2007-10-04 16:18:26.000000000 +0200
|
+++ sangam_atm-D7.03.01.00/tn7sar.c 2008-01-05 03:11:03.000000000 +0100
|
||||||
@@ -42,7 +42,6 @@
|
@@ -42,7 +42,6 @@
|
||||||
* UR8_MERGE_END CQ10700
|
* UR8_MERGE_END CQ10700
|
||||||
*******************************************************************************/
|
*******************************************************************************/
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -ur atm.old/tn7atm.c atm.dev/tn7atm.c
|
diff -urN sangam_atm-D7.03.01.00.orig/tn7atm.c sangam_atm-D7.03.01.00/tn7atm.c
|
||||||
--- atm.old/tn7atm.c 2007-04-20 21:04:28.479287240 +0200
|
--- sangam_atm-D7.03.01.00.orig/tn7atm.c 2008-01-05 03:11:23.000000000 +0100
|
||||||
+++ atm.dev/tn7atm.c 2007-04-20 21:09:05.288205888 +0200
|
+++ sangam_atm-D7.03.01.00/tn7atm.c 2008-01-05 03:11:34.000000000 +0100
|
||||||
@@ -568,7 +568,7 @@
|
@@ -566,7 +566,7 @@
|
||||||
* Description: tnetd73xx SAR interrupt.
|
* Description: tnetd73xx SAR interrupt.
|
||||||
*
|
*
|
||||||
*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~*/
|
*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~*/
|
||||||
@ -10,7 +10,7 @@ diff -ur atm.old/tn7atm.c atm.dev/tn7atm.c
|
|||||||
{
|
{
|
||||||
struct atm_dev *atmdev;
|
struct atm_dev *atmdev;
|
||||||
Tn7AtmPrivate *priv;
|
Tn7AtmPrivate *priv;
|
||||||
@@ -595,6 +595,7 @@
|
@@ -593,6 +593,7 @@
|
||||||
#ifdef TIATM_INST_SUPP
|
#ifdef TIATM_INST_SUPP
|
||||||
psp_trace_par (ATM_DRV_SAR_ISR_EXIT, retval);
|
psp_trace_par (ATM_DRV_SAR_ISR_EXIT, retval);
|
||||||
#endif
|
#endif
|
||||||
@ -18,7 +18,7 @@ diff -ur atm.old/tn7atm.c atm.dev/tn7atm.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
/*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
/*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||||
@@ -604,7 +604,7 @@
|
@@ -602,7 +603,7 @@
|
||||||
* Description: tnetd73xx DSL interrupt.
|
* Description: tnetd73xx DSL interrupt.
|
||||||
*
|
*
|
||||||
*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~*/
|
*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~*/
|
||||||
@ -27,7 +27,7 @@ diff -ur atm.old/tn7atm.c atm.dev/tn7atm.c
|
|||||||
{
|
{
|
||||||
struct atm_dev *atmdev;
|
struct atm_dev *atmdev;
|
||||||
Tn7AtmPrivate *priv;
|
Tn7AtmPrivate *priv;
|
||||||
@@ -626,6 +626,8 @@
|
@@ -624,6 +625,8 @@
|
||||||
#ifdef TIATM_INST_SUPP
|
#ifdef TIATM_INST_SUPP
|
||||||
psp_trace_par (ATM_DRV_DSL_ISR_EXIT, retval);
|
psp_trace_par (ATM_DRV_DSL_ISR_EXIT, retval);
|
||||||
#endif
|
#endif
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
--- sangam_atm-07.01.00.10/tn7api.h 2006-10-26 16:48:34.000000000 +0200
|
diff -urN sangam_atm-D7.03.01.00.orig/tn7api.h sangam_atm-D7.03.01.00/tn7api.h
|
||||||
+++ sangam_atm-07.01.00.10.new/tn7api.h 2007-07-24 12:43:04.000000000 +0200
|
--- sangam_atm-D7.03.01.00.orig/tn7api.h 2006-12-11 15:36:54.000000000 +0100
|
||||||
@@ -110,7 +110,7 @@
|
+++ sangam_atm-D7.03.01.00/tn7api.h 2008-01-05 03:12:15.000000000 +0100
|
||||||
|
@@ -107,7 +107,7 @@
|
||||||
|
|
||||||
int tn7dsl_proc_write_stats(struct file *fp, const char * buf, unsigned long count, void * data);
|
int tn7dsl_proc_write_stats(struct file *fp, const char * buf, unsigned long count, void * data);
|
||||||
int tn7dsl_proc_modem(char* buf, char **start, off_t offset, int count,int *eof, void *data);
|
int tn7dsl_proc_modem(char* buf, char **start, off_t offset, int count,int *eof, void *data);
|
||||||
|
@ -1,6 +1,36 @@
|
|||||||
--- atm.old/tn7dsl.c 2006-10-26 16:48:44.000000000 +0200
|
diff -urN sangam_atm-D7.03.01.00.orig/dsl_hal_advcfg.c sangam_atm-D7.03.01.00/dsl_hal_advcfg.c
|
||||||
+++ atm.dev/tn7dsl.c 2007-06-22 23:36:27.000000000 +0200
|
--- sangam_atm-D7.03.01.00.orig/dsl_hal_advcfg.c 2005-08-09 09:20:46.000000000 +0200
|
||||||
@@ -2867,6 +2814,14 @@
|
+++ sangam_atm-D7.03.01.00/dsl_hal_advcfg.c 2008-01-05 03:12:50.000000000 +0100
|
||||||
|
@@ -36,9 +36,9 @@
|
||||||
|
* 05Jul05 0.00.09 CPH CQ9775: Change dslhal_advcfg_configDsTones input parameters & support for ADSL2+
|
||||||
|
* 24Jul05 0.00.10 CPH Fixed comments in dslhal_advcfg_configDsTones function header
|
||||||
|
*******************************************************************************/
|
||||||
|
-#include <dev_host_interface.h>
|
||||||
|
-#include <dsl_hal_register.h>
|
||||||
|
-#include <dsl_hal_support.h>
|
||||||
|
+#include "dev_host_interface.h"
|
||||||
|
+#include "dsl_hal_register.h"
|
||||||
|
+#include "dsl_hal_support.h"
|
||||||
|
|
||||||
|
/*****************************************************************************/
|
||||||
|
/* ACT API functions -- To be moved into their own independent module --RamP */
|
||||||
|
diff -urN sangam_atm-D7.03.01.00.orig/Makefile sangam_atm-D7.03.01.00/Makefile
|
||||||
|
--- sangam_atm-D7.03.01.00.orig/Makefile 2008-01-05 03:11:23.000000000 +0100
|
||||||
|
+++ sangam_atm-D7.03.01.00/Makefile 2008-01-05 03:12:50.000000000 +0100
|
||||||
|
@@ -4,6 +4,7 @@
|
||||||
|
|
||||||
|
CONFIG_SANGAM_ATM=m
|
||||||
|
#EXTRA_CFLAGS += -DEL -I. -DPOST_SILICON -DCOMMON_NSP -DCONFIG_LED_MODULE -DDEREGISTER_LED -DNO_ACT
|
||||||
|
-EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
|
||||||
|
+#EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
|
||||||
|
+EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -D__NO__VOICE_PATCH__ -DEL
|
||||||
|
obj-$(CONFIG_SANGAM_ATM) := tiatm.o
|
||||||
|
-tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o
|
||||||
|
+tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o dsl_hal_advcfg.o
|
||||||
|
diff -urN sangam_atm-D7.03.01.00.orig/tn7dsl.c sangam_atm-D7.03.01.00/tn7dsl.c
|
||||||
|
--- sangam_atm-D7.03.01.00.orig/tn7dsl.c 2008-01-05 03:11:23.000000000 +0100
|
||||||
|
+++ sangam_atm-D7.03.01.00/tn7dsl.c 2008-01-05 03:12:50.000000000 +0100
|
||||||
|
@@ -2869,6 +2869,14 @@
|
||||||
dslhal_api_setRateAdaptFlag(pIhw, os_atoi(ptr));
|
dslhal_api_setRateAdaptFlag(pIhw, os_atoi(ptr));
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -15,30 +45,3 @@
|
|||||||
// trellis
|
// trellis
|
||||||
ptr = NULL;
|
ptr = NULL;
|
||||||
ptr = prom_getenv("trellis");
|
ptr = prom_getenv("trellis");
|
||||||
--- atm.old/Makefile 2007-06-24 18:46:25.000000000 +0200
|
|
||||||
+++ atm.dev/Makefile 2007-06-24 18:46:31.000000000 +0200
|
|
||||||
@@ -4,6 +4,7 @@
|
|
||||||
|
|
||||||
CONFIG_SANGAM_ATM=m
|
|
||||||
#EXTRA_CFLAGS += -DEL -I. -DPOST_SILICON -DCOMMON_NSP -DCONFIG_LED_MODULE -DDEREGISTER_LED -DNO_ACT
|
|
||||||
-EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
|
|
||||||
+#EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
|
|
||||||
+EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -D__NO__VOICE_PATCH__ -DEL
|
|
||||||
obj-$(CONFIG_SANGAM_ATM) := tiatm.o
|
|
||||||
-tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o
|
|
||||||
+tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o dsl_hal_advcfg.o
|
|
||||||
--- atm.old/dsl_hal_advcfg.c 2007-06-24 19:22:42.000000000 +0200
|
|
||||||
+++ atm.dev/dsl_hal_advcfg.c 2007-06-24 19:21:42.000000000 +0200
|
|
||||||
@@ -36,9 +36,9 @@
|
|
||||||
* 05Jul05 0.00.09 CPH CQ9775: Change dslhal_advcfg_configDsTones input parameters & support for ADSL2+
|
|
||||||
* 24Jul05 0.00.10 CPH Fixed comments in dslhal_advcfg_configDsTones function header
|
|
||||||
*******************************************************************************/
|
|
||||||
-#include <dev_host_interface.h>
|
|
||||||
-#include <dsl_hal_register.h>
|
|
||||||
-#include <dsl_hal_support.h>
|
|
||||||
+#include "dev_host_interface.h"
|
|
||||||
+#include "dsl_hal_register.h"
|
|
||||||
+#include "dsl_hal_support.h"
|
|
||||||
|
|
||||||
/*****************************************************************************/
|
|
||||||
/* ACT API functions -- To be moved into their own independent module --RamP */
|
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
--- atm.old/tn7sar.c 2007-06-25 13:25:44.000000000 +0200
|
diff -urN sangam_atm-D7.03.01.00.orig/tn7sar.c sangam_atm-D7.03.01.00/tn7sar.c
|
||||||
+++ atm.dev/tn7sar.c 2007-06-25 13:26:33.000000000 +0200
|
--- sangam_atm-D7.03.01.00.orig/tn7sar.c 2008-01-05 03:11:23.000000000 +0100
|
||||||
@@ -102,10 +102,10 @@
|
+++ sangam_atm-D7.03.01.00/tn7sar.c 2008-01-05 03:13:22.000000000 +0100
|
||||||
|
@@ -103,10 +103,10 @@
|
||||||
|
|
||||||
#define RESERVED_OAM_CHANNEL 15
|
#define RESERVED_OAM_CHANNEL 15
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user