diff --git a/tools/bison/Makefile b/tools/bison/Makefile
index 10d8720484..256512116f 100644
--- a/tools/bison/Makefile
+++ b/tools/bison/Makefile
@@ -23,4 +23,9 @@ define Host/Clean
 	$(call Host/Clean/Default)
 endef
 
+define Host/Install
+	$(call Host/Install/Default)
+	$(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
+
 $(eval $(call HostBuild))
diff --git a/tools/bison/scripts/yacc b/tools/bison/scripts/yacc
new file mode 100755
index 0000000000..8f73e26fb1
--- /dev/null
+++ b/tools/bison/scripts/yacc
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec bison -y "$@"