thc-ipv6: update to 3.8
Remove upstreamed patches: - 000-cflags_override.patch Manually refresh patches: - 100-no-ssl.patch Add patches: - 101-remove-march-native.patch Add THC_APPLETS: - toobigsniff6 - flood_unreach6 - connect6 Signed-off-by: Nick Hainke <vincent@systemli.org>
This commit is contained in:
parent
b6d850317b
commit
5479281c72
|
@ -8,13 +8,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=thc-ipv6
|
PKG_NAME:=thc-ipv6
|
||||||
PKG_VERSION:=2.7
|
PKG_VERSION:=3.8
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_LICENSE:=GPL-3.0
|
PKG_LICENSE:=GPL-3.0
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@GITHUB/vanhauser-thc/THC-Archive/master/Tools
|
PKG_SOURCE_URL:=@GITHUB/vanhauser-thc/THC-Archive/master/Tools
|
||||||
PKG_HASH:=440a3ae98b57100c397ec4f8634468dbbb0c3b48788c6b74af2a597a90544a96
|
PKG_HASH:=b60be61a8b0a944a66e3b719704b4c03c1bc2c22f32d5d21e99e434c82a9d769
|
||||||
|
|
||||||
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
|
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
|
||||||
|
|
||||||
|
@ -31,7 +31,7 @@ THC_APPLETS := \
|
||||||
fuzz_dhcps6 implementation6 implementation6d inverse_lookup6 \
|
fuzz_dhcps6 implementation6 implementation6d inverse_lookup6 \
|
||||||
kill_router6 ndpexhaust6 node_query6 parasite6 passive_discovery6 \
|
kill_router6 ndpexhaust6 node_query6 parasite6 passive_discovery6 \
|
||||||
randicmp6 redir6 rsmurf6 sendpees6 sendpeesmp6 smurf6 thcping6 \
|
randicmp6 redir6 rsmurf6 sendpees6 sendpeesmp6 smurf6 thcping6 \
|
||||||
toobig6 trace6
|
toobig6 trace6 toobigsniff6 flood_unreach6 connect6
|
||||||
|
|
||||||
THC_DEPENDS_dnsdict6 := +libpthread
|
THC_DEPENDS_dnsdict6 := +libpthread
|
||||||
THC_DEPENDS_thcping6 := +librt
|
THC_DEPENDS_thcping6 := +librt
|
||||||
|
|
|
@ -1,9 +1,10 @@
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -1,5 +1,5 @@
|
@@ -1,6 +1,6 @@
|
||||||
# Comment out if openssl-dev is not present
|
# Comment out if openssl-dev is not present
|
||||||
|
# of if you want to compile statc
|
||||||
-HAVE_SSL=yes
|
-HAVE_SSL=yes
|
||||||
+#HAVE_SSL=yes
|
+#HAVE_SSL=yes
|
||||||
|
|
||||||
CC=gcc
|
# comment in if you want to compile static tools
|
||||||
#CFLAGS=-g
|
#STATIC=-static
|
||||||
|
|
|
@ -1,12 +1,11 @@
|
||||||
diff -urN thc-ipv6-2.7/Makefile thc-ipv6-2.7.new/Makefile
|
--- a/Makefile
|
||||||
--- thc-ipv6-2.7/Makefile 2014-12-27 05:05:30.000000000 -0800
|
+++ b/Makefile
|
||||||
+++ thc-ipv6-2.7.new/Makefile 2017-02-04 20:55:51.679898101 -0800
|
@@ -7,7 +7,7 @@ HAVE_SSL=yes
|
||||||
@@ -3,7 +3,7 @@
|
|
||||||
|
|
||||||
CC=gcc
|
#CC=gcc
|
||||||
#CFLAGS=-g
|
#CFLAGS=-g
|
||||||
-CFLAGS=-O2
|
-CFLAGS+=-g -O3 -march=native -flto -falign-functions -falign-jumps -falign-loops -falign-labels -freorder-blocks
|
||||||
+CFLAGS?=-O2
|
+CFLAGS+=-g -O3 -flto -falign-functions -falign-jumps -falign-loops -falign-labels -freorder-blocks
|
||||||
CFLAGS+=$(if $(HAVE_SSL),-D_HAVE_SSL,)
|
CFLAGS+=$(if $(HAVE_SSL),-D_HAVE_SSL,)
|
||||||
LDFLAGS+=-lpcap $(if $(HAVE_SSL),-lssl -lcrypto,)
|
LDFLAGS+=-lpcap $(if $(HAVE_SSL),-lssl -lcrypto,)
|
||||||
PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 flood_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 covert_send6 covert_send6d inject_alive6 firewall6 ndpexhaust26 fake_pim6 thcsyn6 redirsniff6 flood_redir6 four2six dump_dhcp6 fuzz_dhcps6 flood_rs6 fuzz_dhcpc6
|
PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 flood_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 covert_send6 covert_send6d inject_alive6 firewall6 ndpexhaust26 fake_pim6 thcsyn6 redirsniff6 flood_redir6 four2six dump_dhcp6 flood_rs6 fuzz_dhcps6 fuzz_dhcpc6 toobigsniff6 flood_unreach6 connect6
|
Loading…
Reference in New Issue