diff --git a/openwrt/target/utils/Makefile b/openwrt/target/utils/Makefile
index b4c1a21ee0..c08bd1a55d 100644
--- a/openwrt/target/utils/Makefile
+++ b/openwrt/target/utils/Makefile
@@ -12,6 +12,9 @@ install: compile
 package:
 clean:
 	rm -rf $(UTILS_BUILD_DIR)
+	for f in $(TARGETS); do \
+		rm -f $(STAGING_DIR)/bin/$$f ; \
+	done
 
 $(UTILS_BUILD_DIR):
 	mkdir -p $(UTILS_BUILD_DIR)