Remove telegram

This commit is contained in:
Alex D. 2021-04-03 17:05:29 +00:00
parent 4df85750b6
commit a66943f962
Signed by: caskd
GPG Key ID: F92BA85F61F4C173
6 changed files with 0 additions and 361 deletions

View File

@ -1,85 +0,0 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer:
pkgname=telegram-desktop
pkgver=2.6.1
pkgrel=0
pkgdesc="Telegram Desktop messaging app"
options="!check" # Requires Catch2 to be packaged.
url="https://desktop.telegram.org/"
# x86: textrels in tg_owt
# s390x, mips, mips64: Need support on lib_base
arch="all !x86 !s390x !mips !mips64 armhf"
license="GPL-3.0-or-later WITH OpenSSL"
depends="qt5-qtimageformats ttf-opensans"
makedepends="
alsa-lib-dev
cmake
enchant2-dev
ffmpeg-dev
hunspell-dev
libjpeg-turbo-dev
libexecinfo-dev
libexif-dev
libva-dev
libvdpau-dev
libxkbcommon-dev
lz4-dev
minizip-dev
openal-soft-dev
openssl-dev
opus-dev
portaudio-dev
pulseaudio-dev
python3
qtchooser
qt5-qtbase-dev
qt5-qtsvg-dev
qt5-qtlottie-dev
range-v3-dev
tl-expected
xcb-util-keysyms-dev
xxhash-dev
xz-dev
zlib-dev
"
source="
https://github.com/telegramdesktop/tdesktop/releases/download/v$pkgver/tdesktop-$pkgver-full.tar.gz
remove-glibc.patch
small-sizes.patch
remove-calls.patch
"
builddir="$srcdir/tdesktop-$pkgver-full"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
cmake -B build \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=Release \
-DTDESKTOP_API_ID=611335 \
-DTDESKTOP_API_HASH=d524b414d21f4d37f08684c1df41ac9c \
-DDESKTOP_APP_USE_GLIBC_WRAPS=OFF \
-DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON \
-DDESKTOP_APP_DISABLE_DBUS_INTEGRATION=ON \
-DDESKTOP_APP_DISABLE_WAYLAND_INTEGRATION=ON \
-DDESKTOP_APP_DISABLE_GTK_INTEGRATION=ON \
-DDESKTOP_APP_DISABLE_AUTOUPDATE=ON \
-DDESKTOP_APP_USE_PACKAGED=ON \
-DDESKTOP_APP_USE_PACKAGED_FONTS=ON \
-DDESKTOP_APP_SPECIAL_TARGET="" \
-DTDESKTOP_LAUNCHER_BASENAME=telegram-desktop \
$CMAKE_CROSSOPTS .
make -C build
}
package() {
DESTDIR="$pkgdir" make -C build install
}
sha512sums="92506477ee1778f7528d8b914406cbf04abf1941d4f1a5d61b75dbf393df2184da1f4f83bbc343e221a539c7a01d3e3b3fe5286453d2bf1863b75ea922b70d5a tdesktop-2.6.1-full.tar.gz
b276001d1616cb5dbacbcd18510d0bd4b9d9f7b7a895b05fb6329866f5bdb7b69f536f7d7914436c8ea975c4f7951a2bb3efd9209c38df115b1d85e0ed099b04 remove-glibc.patch
3d1b8e6f870fc780f9ae8bc6a67eb676a5c5f686dc79e84cd6d64cb3cfafb1be626d0cc3960ffc67cecca21568764a0137c7303a89045fa59f91ba4eb5d8caed small-sizes.patch
11c57af7d3e9651ea76019c4cd8c6416c792fd5288ffd4e2d9357c81256a95c0e1b0a8c9fdad2d062a143f8d251695024693cbc1c8dcd0387d6858b706fda217 remove-calls.patch"

View File

@ -1,28 +0,0 @@
--- a/Telegram/ThirdParty/tgcalls/tgcalls/group/GroupInstanceImpl.cpp
+++ b/Telegram/ThirdParty/tgcalls/tgcalls/group/GroupInstanceImpl.cpp
@@ -569,7 +569,7 @@
virtual void OnInterestingUsage(int usage_pattern) override {
}
- virtual void OnErrorDemuxingPacket(uint32_t ssrc) override {
+ virtual void OnErrorDemuxingPacket(uint32_t ssrc) {
_onMissingSsrc(ssrc);
}
};
@@ -1207,16 +1207,6 @@
apm->ApplyConfig(audioConfig);
mediaDeps.audio_processing = apm;
-
- mediaDeps.onUnknownAudioSsrc = [weak](uint32_t ssrc) {
- getMediaThread()->PostTask(RTC_FROM_HERE, [weak, ssrc](){
- auto strong = weak.lock();
- if (!strong) {
- return;
- }
- strong->onMissingSsrc(ssrc);
- });
- };
dependencies.media_engine = cricket::CreateMediaEngine(std::move(mediaDeps));
dependencies.call_factory = webrtc::CreateCallFactory();

View File

@ -1,11 +0,0 @@
--- a/cmake/external/webrtc/CMakeLists.txt
+++ b/cmake/external/webrtc/CMakeLists.txt
@@ -9,7 +9,7 @@
if (DESKTOP_APP_USE_PACKAGED)
find_package(tg_owt REQUIRED)
- target_link_libraries(external_webrtc INTERFACE tg_owt::tg_owt)
+ target_link_libraries(external_webrtc INTERFACE tg_owt::tg_owt INTERFACE jpeg)
else()
set(webrtc_loc ${libs_loc}/tg_owt/src)
set(webrtc_build_loc ${libs_loc}/tg_owt/out/$<CONFIG>)

View File

@ -1,150 +0,0 @@
--- a/Telegram/CMakeLists.txt
+++ b/Telegram/CMakeLists.txt
@@ -18,7 +18,7 @@ endif()
add_subdirectory(lib_storage)
add_subdirectory(lib_lottie)
add_subdirectory(lib_qr)
-add_subdirectory(lib_webrtc)
+#add_subdirectory(lib_webrtc)
add_subdirectory(codegen)
get_filename_component(src_loc SourceFiles REALPATH)
@@ -26,8 +26,8 @@ get_filename_component(res_loc Resources REALPATH)
include(cmake/telegram_options.cmake)
include(cmake/lib_ffmpeg.cmake)
-include(cmake/lib_tgvoip.cmake)
-include(cmake/lib_tgcalls.cmake)
+#include(cmake/lib_tgvoip.cmake)
+#include(cmake/lib_tgcalls.cmake)
include(cmake/td_export.cmake)
include(cmake/td_mtproto.cmake)
include(cmake/td_lang.cmake)
@@ -39,15 +39,15 @@ set_target_properties(Telegram PROPERTIES AUTOMOC ON AUTORCC ON)
target_link_libraries(Telegram
PRIVATE
- tdesktop::lib_tgcalls_legacy
- tdesktop::lib_tgcalls
- tdesktop::lib_tgvoip
+# tdesktop::lib_tgcalls_legacy
+# tdesktop::lib_tgcalls
+# tdesktop::lib_tgvoip
tdesktop::td_export
tdesktop::td_mtproto
tdesktop::td_lang
tdesktop::td_scheme
tdesktop::td_ui
- desktop-app::lib_webrtc
+# desktop-app::lib_webrtc
desktop-app::lib_base
desktop-app::lib_crl
desktop-app::lib_ui
@@ -258,35 +258,35 @@ PRIVATE
boxes/url_auth_box.h
boxes/username_box.cpp
boxes/username_box.h
- calls/calls_box_controller.cpp
- calls/calls_box_controller.h
- calls/calls_call.cpp
- calls/calls_call.h
- calls/calls_group_call.cpp
- calls/calls_group_call.h
- calls/calls_group_common.h
- calls/calls_group_members.cpp
- calls/calls_group_members.h
- calls/calls_group_panel.cpp
- calls/calls_group_panel.h
- calls/calls_group_settings.cpp
- calls/calls_group_settings.h
- calls/calls_emoji_fingerprint.cpp
- calls/calls_emoji_fingerprint.h
- calls/calls_instance.cpp
- calls/calls_instance.h
- calls/calls_panel.cpp
- calls/calls_panel.h
- calls/calls_signal_bars.cpp
- calls/calls_signal_bars.h
- calls/calls_top_bar.cpp
- calls/calls_top_bar.h
- calls/calls_userpic.cpp
- calls/calls_userpic.h
- calls/calls_video_bubble.cpp
- calls/calls_video_bubble.h
- calls/calls_volume_item.cpp
- calls/calls_volume_item.h
+# calls/calls_box_controller.cpp
+# calls/calls_box_controller.h
+# calls/calls_call.cpp
+# calls/calls_call.h
+# calls/calls_group_call.cpp
+# calls/calls_group_call.h
+# calls/calls_group_common.h
+# calls/calls_group_members.cpp
+# calls/calls_group_members.h
+# calls/calls_group_panel.cpp
+# calls/calls_group_panel.h
+# calls/calls_group_settings.cpp
+# calls/calls_group_settings.h
+# calls/calls_emoji_fingerprint.cpp
+# calls/calls_emoji_fingerprint.h
+# calls/calls_instance.cpp
+# calls/calls_instance.h
+# calls/calls_panel.cpp
+# calls/calls_panel.h
+# calls/calls_signal_bars.cpp
+# calls/calls_signal_bars.h
+# calls/calls_top_bar.cpp
+# calls/calls_top_bar.h
+# calls/calls_userpic.cpp
+# calls/calls_userpic.h
+# calls/calls_video_bubble.cpp
+# calls/calls_video_bubble.h
+# calls/calls_volume_item.cpp
+# calls/calls_volume_item.h
chat_helpers/bot_keyboard.cpp
chat_helpers/bot_keyboard.h
chat_helpers/emoji_keywords.cpp
@@ -922,8 +922,8 @@ PRIVATE
settings/settings_advanced.h
settings/settings_chat.cpp
settings/settings_chat.h
- settings/settings_calls.cpp
- settings/settings_calls.h
+# settings/settings_calls.cpp
+# settings/settings_calls.h
settings/settings_codes.cpp
settings/settings_codes.h
settings/settings_common.cpp
--- a/cmake/external/CMakeLists.txt
+++ b/cmake/external/CMakeLists.txt
@@ -63,7 +63,7 @@ if (LINUX AND NOT DESKTOP_APP_DISABLE_DBUS_INTEGRATION)
endif()
add_checked_subdirectory(ton)
add_checked_subdirectory(variant)
-add_checked_subdirectory(webrtc)
+#add_checked_subdirectory(webrtc)
if (LINUX AND NOT DESKTOP_APP_DISABLE_X11_INTEGRATION)
add_checked_subdirectory(xcb)
endif()
--- a/Telegram/SourceFiles/core/core_settings.cpp
+++ b/Telegram/SourceFiles/core/core_settings.cpp
@@ -13,7 +13,6 @@ https://github.com/telegramdesktop/tdesktop/blob/master/LEGAL
#include "window/themes/window_theme.h"
#include "window/section_widget.h"
#include "base/platform/base_platform_info.h"
-#include "webrtc/webrtc_create_adm.h"
#include "facades.h"
namespace Core {
@@ -497,10 +496,6 @@ void Settings::setTabbedReplacedWithInfo(bool enabled) {
}
}
-Webrtc::Backend Settings::callAudioBackend() const {
- return Webrtc::Backend::OpenAL;
-}
-
void Settings::setDialogsWidthRatio(float64 ratio) {
_dialogsWidthRatio = ratio;
}

View File

@ -1,39 +0,0 @@
diff --git a/Telegram/lib_base/base/platform/linux/base_info_linux.cpp b/Telegram/lib_base/base/platform/linux/base_info_linux.cpp
index cff7136..ced69bd 100644
--- a/Telegram/lib_base/base/platform/linux/base_info_linux.cpp
+++ b/Telegram/lib_base/base/platform/linux/base_info_linux.cpp
@@ -12,11 +12,6 @@
#include <QtCore/QDate>
#include <QtGui/QGuiApplication>
-// this file is used on both Linux & BSD
-#ifdef Q_OS_LINUX
-#include <gnu/libc-version.h>
-#endif // Q_OS_LINUX
-
namespace Platform {
namespace {
@@ -124,21 +119,13 @@ QString AutoUpdateKey() {
QString GetLibcName() {
#ifdef Q_OS_LINUX
- return "glibc";
+ return "musl";
#endif // Q_OS_LINUX
return QString();
}
QString GetLibcVersion() {
-#ifdef Q_OS_LINUX
- static const auto result = [&] {
- const auto version = QString::fromLatin1(gnu_get_libc_version());
- return QVersionNumber::fromString(version).isNull() ? QString() : version;
- }();
- return result;
-#endif // Q_OS_LINUX
-
return QString();
}

View File

@ -1,48 +0,0 @@
From 675b5d645221bae9d9ad2cc7dd62d30a3b0f95c3 Mon Sep 17 00:00:00 2001
From: Julian Sparber <julian@sparber.net>
Date: Thu, 14 Nov 2019 17:36:33 +0100
Subject: [PATCH] Make it work on small sizes
---
Telegram/SourceFiles/settings/settings_main.cpp | 2 +-
Telegram/SourceFiles/window/window.style | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/Telegram/SourceFiles/settings/settings_main.cpp b/Telegram/SourceFiles/settings/settings_main.cpp
index 18552902b..c2d8e7a4d 100644
--- a/Telegram/SourceFiles/settings/settings_main.cpp
+++ b/Telegram/SourceFiles/settings/settings_main.cpp
@@ -100,7 +100,7 @@ void SetupSections(
}
bool HasInterfaceScale() {
- return true;
+ return false;
}
void SetupInterfaceScale(
diff --git a/Telegram/SourceFiles/window/window.style b/Telegram/SourceFiles/window/window.style
index b3cd3ae83..29bf8bc3c 100644
--- a/Telegram/SourceFiles/window/window.style
+++ b/Telegram/SourceFiles/window/window.style
@@ -10,7 +10,7 @@ using "basic.style";
using "ui/widgets/widgets.style";
using "history/history.style";
-windowMinWidth: 380px;
+windowMinWidth: 360px;
windowMinHeight: 480px;
windowDefaultWidth: 800px;
windowDefaultHeight: 600px;
@@ -19,7 +19,7 @@ windowShadowShift: 1px;
columnMinimalWidthLeft: 260px;
columnMaximalWidthLeft: 540px;
-columnMinimalWidthMain: 380px;
+columnMinimalWidthMain: 360px;
columnDesiredWidthMain: 512px;
columnMinimalWidthThird: 292px;
columnMaximalWidthThird: 392px;
--
2.24.1