37 lines
771 B
Plaintext
37 lines
771 B
Plaintext
# Contributor: Alex Denes <caskd@redxen.eu>
|
|
# Maintainer: Alex Denes <caskd@redxen.eu>
|
|
|
|
. ../APKBUILD-data.template
|
|
|
|
pkgver=0.4.1
|
|
pkgrel=4
|
|
makedepends="
|
|
deno
|
|
npm
|
|
"
|
|
url="https://gitea.catppuccin.com/catppuccin/gitea"
|
|
source="
|
|
$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
|
|
"
|
|
_customroot="/usr/share/gitea/custom"
|
|
_rx_installdir="$_customroot/public/assets/css"
|
|
_rx_fperm=444 # Public, static resources
|
|
builddir="$srcdir/gitea"
|
|
|
|
prepare() {
|
|
default_prepare
|
|
mkdir -p node_modules
|
|
}
|
|
|
|
build() {
|
|
deno task build
|
|
}
|
|
|
|
package() {
|
|
rx_install dist/theme-catppuccin-mocha-flamingo.css
|
|
}
|
|
|
|
sha512sums="
|
|
0f9e9946551109cab618778183a6d7f7a03792fe9533da9a7379b26c1727602b1f9b44d4d705ae96007a49bed340d516ce434dab98e6a69f38ebcfa121c038c6 redxen-data-catppuccin-0.4.1.tar.gz
|
|
"
|